SharePoint 2013: InfoPath Forms Services funktionieren nicht

Ein Problem, das mir bei der Konfiguration eines neuen SharePoint 2013 Server untergekommen ist:
Fehler

Fehler beim Laden des Formulars.
Detailierter Fehler:

Auf den folgenden Speicherort kann nicht zugegriffen werden, da er sich in einer anderen Websitesammlung befindet: ‘https://ServernameDerMaschine/PA/BM/Formulare/Forms/template.xsn?SaveLocation=https://VirtuellerNamederWebApp/PA/BM/Formulare/&
Source=https://VirtuellerNamederWebApp/PA/BM/Formulare/Forms/AllItems.aspx&
ClientInstalled=false&OpenIn=Browser&NoRedirect=true&
XsnLocation=https://ServernameDerMaschine/PA/BM/Formulare/Forms/template.xsn’.

Auffällig ist, das die Anwendung wild die Servernamen durcheinender würfelt. Und warum es nicht funktioniert ist damit auch klar. Auf dem Namen der Maschine hängt kein WEB- Server. Schon gar nicht dieselbe Websitesammlung. So weit, so einfach, aber warum ist das so?

Nach einigem Forschen hab ich es dann gefunden. Grund ist das in SharePoint 2013 neu eingeführte “Request Management”. Im Detail wird das Ganze bei harbar.net erklärt.

Kurz zusammengefasst kümmert sich die Komponente darum ankommende Anforderungen nach bestimmten Kriterien auf alle WEB Server zu verteilen. Dafür gibt es ein entsprechendes Regelwerk. Nur leider funktioniert das für die Forms Services eben nicht.

Abhilfe schafft das Abschalten der Komponente mit Hilfe der Powershell:

$webApp = Get-SPWebApplication http://webapphostname
$reqSettings = $webApp | Get-SPRequestManagementSettings
$reqSettings.RoutingEnabled = $false
$reqSettings.Update()

War bei mit jetzt kein Problem, da meine Farm eh nur aus einem WEB- Server besteht. Nach einer praktikablen Lösung für eine große Farm suche ich noch….

Einen Kommentar schreiben

Your email address will not be published. Required fields are marked *