Blog

Firewall Regeln in unbeaufsichtigter Windows Installation aktivieren

Gepostet von am Jun 12, 2019 in Uncategorized | Keine Kommentare

Aus dem Leben: Aufgabe war, eine automatisierte Installation eines Windows 2016 Servers zu generieren, bei der sofort RDP aktiv ist. Sieht einfach aus, ist auch überall dokumentiert, z.B. hier. Funktioniert auch soweit, bis auf das Aktivieren der nötigen Firewall Regeln. Meine erste Idee war, das es ein Problem mit der deutschen Serverversion ist, weil die Regelgruppe, die aktiviert werden soll, im Deutschen „Remotedesktop“ heißt (statt „Remote Desktop“ im Englischen). War es aber nicht. Nach insgesamt 9! Versuchen habe ich dann das hier gefunden: <FirewallGroups> <FirewallGroup wcm:action="add" wcm:keyValue="RemoteDesktop"> <Active>true</Active> <Group>@FirewallAPI.dll,-28752</Group> <Profile>all</Profile> </FirewallGroup> </FirewallGroups> Zu beachten die Zeile „@FirewallAPI.dll,-28752“. Ich war also schon auf der richtigen Spur. Aber das die Abfrage beim Setup nicht auf den übersetzten Namen, sondern auf den Link in die DLL zur Ressource prüft, darauf bin ich dann doch nicht gekommen. Die komplette Sektion in der unattended.txt für das Aktivieren von RDP sieht für den Windows Server 2016 wie folgt aus: <settings pass="specialize"> <component name="Microsoft-Windows-TerminalServices-LocalSessionManager" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <fDenyTSConnections>false</fDenyTSConnections> </component> <component name="Microsoft-Windows-TerminalServices-RDP-WinStationExtensions" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <UserAuthentication>0</UserAuthentication> </component> <component name="Networking-MPSSVC-Svc" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <FirewallGroups> <FirewallGroup wcm:action="add" wcm:keyValue="RemoteDesktop"> <Active>true</Active> <Group>@FirewallAPI.dll,-28752</Group> <Profile>all</Profile> </FirewallGroup> </FirewallGroups> </component>...

read more

SharePoint führt Workflows doppelt aus…

Gepostet von am Nov 14, 2015 in Uncategorized | Keine Kommentare

Folgende Situation: Beim Eingehen einer E-Mail in einer Dokumentenbibliothek soll in einer Liste per Workflow ein neues Element erstellt werden. Funktioniert auch, aber leider doppelt. Komische Sache. Problem ist die Option „Ursprüngliche E-Mail speichern?“ (siehe Screenshot). In diesem Falle wird der Workflow sowohl für den erstellten Ordner als auch für die gespeicherte E-Mail ausgeführt. Lösung: Einfach in den Workflow eine Bedingung einbauen die überprüft, ob der Content- Type „Ordner“...

read more

Adobe Lightroom CC startet nicht nach Update auf Windows 10 („Missing msvcp110.dll“)

Gepostet von am Jul 26, 2015 in Uncategorized | 2 Kommentare

Wer, wie ich, alle BUILDs von Windows 10 mitnimmt hat auch immer mal wieder mit ein paar spannenden, hauptsächlich aber nervende Problemen zu tun. Letztes Beispiel: Mein Lightroom (und auch Photoshop) starten nach dem Update auf die neue Build nicht mehr: „Missing msvcp110.dll File“ Suche bei einer Suchmaschine meiner Wahl findet das hier. Hilft aber leider nicht, weil die Datei nicht an diesem Platz steht. Gefunden hab ich die richtige vcredist_x64.exe dann hier: C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\Runtime\customhook\vc12\64bit Ist übrigens die Version 11.0.61030. Findet man sicher auch bei Microsoft, wenn man die Version kennt....

read more